Web lists-archives.com

Re: [Samba] classic upgrade fails with 4.6-test




On Mon, 2017-01-30 at 08:42 +0000, Rowland Penny wrote:
> On Mon, 30 Jan 2017 15:44:15 +1300
> Andrew Bartlett <abartlet@xxxxxxxxx> wrote:
> 
> > On Sun, 2017-01-29 at 22:43 +0000, Rowland Penny via samba wrote:
> > > On Sun, 29 Jan 2017 17:07:39 -0500
> > > Sonic <sonicsmith@xxxxxxxxx> wrote:
> > > 
> > > > On Sun, Jan 29, 2017 at 4:54 PM, Rowland Penny <rpenny@xxxxxxxx
> > > > g>
> > > > wrote:
> > > > 
> > > > > When you built Samba, did you use the '--with-ntvfs-
> > > > > fileserver'
> > > > > or
> > > > > '--enable-selftest' options with configure ?
> > > > > 
> > > > 
> > > > I used '--without-ntvfs-fileserver'.
> > > 
> > > OK, this is the code that is producing the error:
> > 
> > Thanks for the analysis!
> > 
> > I think the attached should fix it.  I've filed a bug for it so we
> > get
> > it into 4.6.
> > 
> > Andrew Bartlett
> > 
> 
> Sorry Andrew, but I don't think it will ;-)
> 
> Unless you have built ntvfs, the '--use-xattrs' option doesn't get
> set
> until the 'def' and there it gets set to 'use_xattrs=None' along
> with 
> 'use_ntvfs=False'
> 
> So, by my reading, with your patch the OP is still going to get the
> error message.

Rowland,

I'm a little confused, because I do change the defaults in the function
declaration (the 'def' as you put it).  I also tested it.

Please look again at the changes for 'use_xattrs="auto"'

Thanks,

Andrew Bartlett
-- 
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba