Web lists-archives.com

Re: [Samba] classic upgrade fails with 4.6-test




On Sun, 29 Jan 2017 16:30:43 -0500
Sonic via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Classic upgrade failing with 4.6-test (4.6.0rc3-GIT-1f2ebda) :
> Running:
> samba-tool domain classicupgrade --dbdir=/usr/local/samba.PDC/dbdir/
> --realm=example.com --dns-backend=BIND9_DLZ --use-xattrs=yes
> /usr/local/samba.PDC/etc/smb.PDC.conf
> 
> Gives:
> samba-tool domain classicupgrade: error: no such option: --use-xattrs
> 
> If --use-xattrs=yes is removed:
> 
> samba-tool domain classicupgrade --dbdir=/usr/local/samba.PDC/dbdir/
> --realm=example.com --dns-backend=BIND9_DLZ
> /usr/local/samba.PDC/etc/smb.PDC.conf
> 
> Gives:
> ERROR: --use-xattrs=no requires --use-ntvfs (not supported for
> production use).  Please re-run with --use-xattrs omitted.
> 
> Chris

When you built Samba, did you use the '--with-ntvfs-fileserver' or
'--enable-selftest' options with configure ?

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba