Web lists-archives.com

Re: [PHP] White screen - nothing in logs





> Date: Sunday, May 06, 2018 11:13:26 +0100
> From: Lester Caine <lester@xxxxxxxxxxx>
>
> I've got a new setup which I am moving websites over to. Still
> using PHP7.0 via FPM with Nginx 1.13.9 as that is what SUSE Leap
> 42.3 provides.
> 
> First few sites have been fine, but the latest on is giving me
> white screen crashes. Only on some limited content which is what is
> even stranger, but the problem is there is nothing being written to
> the fpm log file!
> 
> http://npc.smallbrook.co.uk/phpinfo.php is showing that everything
> is set right and the log file is writeable although it is not being
> created by nginx although some errors are appearing in the nginx
> error log! catch_workers_output = yes
> 
> Where do I go next? I'm sure that the error message will cause the
> problem to stick out like a sore thumb
> http://npc.smallbrook.co.uk/fisheye/gallery/44 works fine, but
> http://npc.smallbrook.co.uk/fisheye/gallery/6/ which should be a
> set of galleries is just blank.
> 

As you indicated, the /44 link works fine. With the /6/ one I get a
"404" in some browsers. If I remove the terminating "/" it seems to
work fine too. As a 404 is a server-level error I would expect it to
show in the [web] server logs, not the php one(s). Also, you seem to
be doing something with the configuration for the 404 error response
page so that it's not properly displayed by default.



-- 
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php