Web lists-archives.com

[PHP] error installing enchant-1.1.0 module into php 5.6.19




Hi all,

I downloaded the enchant 1.1.0 module from pecl.php.net. Expanded the
archive and ran:

[root@server-a enchant-1.1.0]# /opt/php-5.6.19/bin/phpize
Configuring for:
PHP Api Version:         20131106
Zend Module Api No:      20131226
Zend Extension Api No:   220131226
Configure goes without any errors. But when I run make, it ends with this
error:

[root@server-a enchant-1.1.0]# make
/bin/sh /root/enchant-1.1.0/libtool --mode=compile cc  -I.
-I/root/enchant-1.1.0 -DPHP_ATOM_INC -I/root/enchant-1.1.0/include
-I/root/enchant-1.1.0/main -I/root/enchant-1.1.0
-I/usr/local/php/include/php -I/usr/local/php/include/php/main
-I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend
-I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib
-I/usr/include/enchant  -DHAVE_CONFIG_H  -g -O2   -c
/root/enchant-1.1.0/enchant.c -o enchant.lo
mkdir .libs
 cc -I. -I/root/enchant-1.1.0 -DPHP_ATOM_INC -I/root/enchant-1.1.0/include
-I/root/enchant-1.1.0/main -I/root/enchant-1.1.0
-I/usr/local/php/include/php -I/usr/local/php/include/php/main
-I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend
-I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib
-I/usr/include/enchant -DHAVE_CONFIG_H -g -O2 -c
/root/enchant-1.1.0/enchant.c  -fPIC -DPIC -o .libs/enchant.o
/root/enchant-1.1.0/enchant.c:127: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
‘__attribute__’ before ‘enchant_functions’
/root/enchant-1.1.0/enchant.c:161: error: ‘enchant_functions’ undeclared
here (not in a function)
/root/enchant-1.1.0/enchant.c: In function
‘zif_enchant_broker_request_pwl_dict’:
/root/enchant-1.1.0/enchant.c:592: error: ‘struct _php_core_globals’ has no
member named ‘safe_mode’
/root/enchant-1.1.0/enchant.c:592: error: ‘CHECKUID_CHECK_FILE_AND_DIR’
undeclared (first use in this function)
/root/enchant-1.1.0/enchant.c:592: error: (Each undeclared identifier is
reported only once
/root/enchant-1.1.0/enchant.c:592: error: for each function it appears in.)
make: *** [enchant.lo] Error 1
I haven't gotten to the 'make install' part because of this error.

I'm running CentOS 6.5.

This is a compiled version of php-5.6.19 and Apache 2.4.16

Can someone please help me get past this error?

Thanks,
Tim

-- 
GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B