Web lists-archives.com

moving inno tables





I moved the data directory of a MySQL installation from one computer to
another. This works for MyISAM tables. Unfortunately I inadvertently
created some INNO tables, and it doesn't seem to work.

The show tables command accurately lists the following the tables from a
longer list

 pospairs                       |
| purchas4                       |

The ls -l command for the directory /usr/local/mysql/data/tcpcurrent shows
what I take to be all the required files for these two tables:

-rw-r-----  1 _mysql  wheel       66152 Jul 28 15:53 pospairs.MYD
-rw-r-----  1 _mysql  wheel       45056 Jul 28 15:53 pospairs.MYI
-rw-r-----  1 _mysql  wheel        8664 Jul 28 15:53 pospairs.frm
-rw-r-----  1 _mysql  wheel       13792 Jul 28 15:53 purchas4.frm
-rw-r-----  1 _mysql  wheel   385875968 Jul 28 15:54 purchas4.ibd


The permissions are identical, and the file sizes seem appropriate. But
the first ISAM file responds while for the INNO file the command

mysql> select spelling from purchas4 where spelling like 'z%';

produces the response:

ERROR 1146 (42S02): Table 'tcpcurrent.purchas4' doesn't exist

I ran a mysql check routine on this, and it appears that all of the INNO
tables are identified as not existing, although it is there on the hard
drive with substantial byte counts.

Is there something I can do about this or is it an intrinsic problem to
moving INNO tables?






Martin Mueller
Professor emeritus of English and Classics
Northwestern University




--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe:    http://lists.mysql.com/mysql