Web lists-archives.com

Re: [MPlayer-dev-eng] [PATCH] configure: fix live555 detection




Hi!

On 2017-01-13 18:31 +0900, KO Myung-Hun wrote:
> live555 detection always fails due to mismatched parameters.
> 
> -----
> P:/tmp/mplayer-configure-30566-10218/tmp.cpp:7 (P:/tmp/cckGybhw.o): Undefined symbol RTSPClient::createNew(UsageEnvironment&, int, char const*, unsigned short) referenced from text segment
> -----
> ---
>  configure | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/configure b/configure
> index bcc71cc..0b210ed 1007 5
> --- a/configure
> +++ b/configure
> @@ -7090,7 +7090,7 @@ if test "$_live" = auto  && test "$networking" = yes ; then
>  #error Please upgrade to version 2006.03.03 or later of the "LIVE555 Streaming Media" libraries - available from <www.live555.com/liveMedia/>
>  #endif
>  #include "BasicUsageEnvironment.hh"
> -int main(void) { RTSPClient::createNew(*BasicUsageEnvironment::createNew(*BasicTaskScheduler::createNew()), 0, "", 0); return 0; }
> +int main(void) { RTSPClient::createNew(*BasicUsageEnvironment::createNew(*BasicTaskScheduler::createNew()), "", 0); return 0; }
>  EOF
>  
>    _live=no
> -- 

Hmm. I can't really follow.

AFAICT there was another parameter *added* somewhen around 2010.

So IMHO it should rather look like:

  int main(void) { RTSPClient::createNew(*BasicUsageEnvironment::createNew(*BasicTaskScheduler::createNew()), "", 0, "", 0); return 0; }


Anyway, for configure both variations will compile and thus enable live555, 
but I think that would not fix the actual usage of the lib in our code:


  libmpdemux/demux_rtp.cpp:149:   rtspClient = RTSPClient::createNew(*env, verbose, "MPlayer", rtsp_transport_http);


I think I haven't used live555 since a long time. Could you test and comment
if it actually worked for you beyond build?

 

  Alexander
_______________________________________________
MPlayer-dev-eng mailing list
MPlayer-dev-eng@xxxxxxxxxxxx
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-dev-eng