Web lists-archives.com

Re: [MPlayer-dev-eng] Bluray input with -demuxer lavf




On 21 September 2014 15:57:19 GMT+01:00, Andy Furniss <adf.lists@xxxxxxxxx> wrote:
>wm4 wrote:
>> On Sun, 21 Sep 2014 10:26:56 +0100
>> Reimar DÃffinger <Reimar.Doeffinger@xxxxxx> wrote:
>>
>>> On Thu, Sep 18, 2014 at 02:06:04PM +0100, Andy Furniss wrote:
>>>> Reimar DÃffinger wrote:
>>>>> On 18 September 2014 00:40:14 CEST, Andy Furniss
><adf.lists@xxxxxxxxx> wrote:
>>>>
>>>>>> On all 3 of my disks (on HD) lavf now works without cache and
>seeking
>>>>>> works on 2 of them.
>>>>>>
>>>>>> One just gets EOF when seeking with lavf with or without cache,
>it
>>>>>> works
>>>>>> without lavf.
>>>>>>
>>>>>> There are two differences from the working - it's encrypted and
>it's
>>>>>> also made up of lots of small .m2ts for multilingual reasons I
>guess
>>>>>> whereas the other 2 the main film is just one large .m2ts.
>>>>>
>>>>> I would bet that if you dumpstream'd the title and tried to seek
>in ffplay you'd get the same issue.
>>>>
>>>> Yes, ffplay can't seek properly on a dumpstream.
>>>
>>> Could you try attached patch (for FFmpeg) on the bluray?
>>> I have not tested it at all though.
>>
>> You don't need this. Bluray works quite well in mpv (as some users
>> report), and there I just forbid demux_lavf to do seeks.
>
>Yea, but I guess it doesn't know a dumpstream is a br, so doesn't work 
>on my sample.

Neither will my patch though.
My patch should only fix seeking with the combination of br:// and demuxer lavf.

_______________________________________________
MPlayer-dev-eng mailing list
MPlayer-dev-eng@xxxxxxxxxxxx
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-dev-eng