Web lists-archives.com

Re: [MPlayer-dev-eng] Bluray input with -demuxer lavf




On Sun, Sep 14, 2014 at 09:34:48PM +0100, Andy Furniss wrote:
> Grozdan wrote:
> >Hi,
> >
> >I've noticed a problem when using Blu-ray input together with demuxer
> >lavf. The MPlayer cmd is as follows
> >
> >mplayer br:// -bluray-device disc.br -vo null -vc dummy -demuxer lavf -frames 1
> >
> >The problem is that MPlayer does not stop after reading one frame
> >(-frames 1) but goes on to read the *full* Blu-ray, until the end. You
> >can imagine doing this on a 30-50GB bluray input. It trashes the disk
> >until it reaches the end of the BD
> >
> >The same goes if you use something simple as: mplayer br://
> >-bluray-device disc.br -demuxer lavf
> >
> >I've tried to get it work but was not able to do it. The only option
> >is to omit -demuxer lavf which then "works" but the terminal gets
> >spammed with error messages and playback is virtually impossible!
> 
> Hmm, so it does - there is a workaround though -
> 
> -cache 20000 "fixes" -demuxer lavf for me testing with an encrypted disc
> dumped on HD (for which I have the vuk of course).

I think there are at least 2 bugs :(.
MPlayer asks bd_seek to seek to a completely nonsense position:
s->pos=548000  newpos=7F94F8105800  new_bufpos=7F94F8106179  buflen=0 
However instead of either seeking to EOF or returning an error, bd_seek
just does nothing.
The bd_seek documentation unfortunately says nothing at all about what
happens for errors.
_______________________________________________
MPlayer-dev-eng mailing list
MPlayer-dev-eng@xxxxxxxxxxxx
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-dev-eng