Web lists-archives.com

Re: [MPlayer-dev-eng] [patch] gui ignores mplayer volume option




Stephen Sheldon wrote on Tue, 22 Jul 2014 12:44:19 -0700:

> Here is a patch for the windows GUI to use the skin defaults for volume
> and balance.

Doesn't work for me.

The guiInfo members get loaded with the defaults, but when GUI_SET_AUDIO is
called they are all 0.

I've spent the whole freaking day to figure out why and didn't know whether
it's a Wine, dsound or thread issue. It turned out that probably it's the
latter, because holding the values in the gui_t gui structure and copying
them into guiInfo later seems to work. (But then, volume and balance control
of the Win32 GUI seem buggy...)

I'm lacking some Windows thread programming experience here. Maybe
someone could explain to me the existence and instance(s) of guiInfo
inside GuiThread() and outside.

> I am still thinking about movie position.

Well, this one is easy. Get widget value of evSetMoviePosition as well and:

Index: gui/win32/interface.c
===================================================================
--- gui/win32/interface.c       (revision 37243)
+++ gui/win32/interface.c       (working copy)
@@ -514,6 +514,8 @@
        gtkAutoSync = autosync;
     }

+    if (guiInfo.Position) guiSetEvent(evSetMoviePosition);
+
     while(GetMessage(&msg, NULL, 0, 0))
     {
         TranslateMessage(&msg);

Ingo
_______________________________________________
MPlayer-dev-eng mailing list
MPlayer-dev-eng@xxxxxxxxxxxx
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-dev-eng