Web lists-archives.com

Re: [MPlayer-dev-eng] [ticket2196] mplayer thinks the streams end at the wrong point




On 14.07.2014, at 22:34, Alexander Strasser <eclipse7@xxxxxxx> wrote:
> Hi all,
> 
>  the ticket mentioned in the subject
> 
>  https://trac.mplayerhq.hu/ticket/2196
> 
> has a sample where mplayer thinks the streams end way before they
> actually do. So the audio stops after about 2s and the video at 6.4s.
> Other players like e.g. ffplay work correctly on that sample.
> 
>  I have made a stupid modification which is attached to that ticket,
> which makes the provided sample playable for me. It is a hack though
> and I do not understand that code well enough to take it further.
> 
>  Maybe someone can come up with a proper fix or point me in the right
> direction.

This approach would just break slideshow videos again.
What that check does is that it sets eof for that substream after we haven't seen any packets for a stream.
Whenever we see a packet, we should reset that counter and eof.
We only should exit, when we see eof on all (actually, all enabled) stream.
This combination, excluding bugs, should only lead to early exit if for 80 demuxer calls we got no output data for any stream. However we should always get data for at least one stream.
So this just should not happen... Though one thing might be that I believe we currently do not wait for subtitle EOF before exiting, just in case this might be the cause...
_______________________________________________
MPlayer-dev-eng mailing list
MPlayer-dev-eng@xxxxxxxxxxxx
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-dev-eng