Web lists-archives.com

Re: [Mingw-users] putwchar not working




> Date: Sun, 11 Sep 2016 05:06:56 +0000 (UTC)
> From: Hisham Sueyllam <sueyllam@xxxxxxxxx>
> Cc: "mingw-users@xxxxxxxxxxxxxxxxxxxxx" <mingw-users@xxxxxxxxxxxxxxxxxxxxx>
> 
> Well, as an experiment I tried the mingw64, and it works fine and prints unicode both Arabic and English in the
> command window, as shown in the attached png image.
> Here is the listing of the program that worked, it prints an 'a' next to my first name in Arabic, to show that it
> prints both latin and other non-latin (Actually my guess any valid utf8 character, or may be just the BMP).
> Note however that from the options menu I changed the font from Lucida console (the default and which did
> not work) to courier new.
> 
> So I am not sure how they did it in the mingw64,project but clearly this takes the blame off Microsoft...

Your image shows that you displayed the text on something that is not
the stock cmd.exe window, I guess some Cygwin console program.  So no,
this doesn't take any blame off Microsoft, because Cygwin uses UTF-8
internally and does support all the stuff we've been discussing,
adding quite a lot of stuff on top of MS stock runtime.

------------------------------------------------------------------------------
_______________________________________________
MinGW-users mailing list
MinGW-users@xxxxxxxxxxxxxxxxxxxxx

This list observes the Etiquette found at 
http://www.mingw.org/Mailing_Lists.
We ask that you be polite and do the same.  Disregard for the list etiquette may cause your account to be moderated.

_______________________________________________
You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
Also: mailto:mingw-users-request@xxxxxxxxxxxxxxxxxxxxx?subject=unsubscribe