Web lists-archives.com

Re: [Mingw-users] libgmp-10.dll was not found

> Date: Wed, 2 Sep 2015 17:34:38 +0300
> From: Ivan Baidakou <the.dmol@xxxxxxxxx>
> I'm trying to build lgeneral [1] for Windows using mingw.
> Unfortunately, there are no instructions how to do that in the project
> itself. When I invoke ./configure script, it emits the warning [2]
> (missing libgmp-10.dll).

According to the screenshot, the problem is with cc1.exe, so it sounds
like your compiler installation is broken.  Can you compile a C
program, or do you get the same error dialog?

On my system, I have 2 copies of libgmp-10.dll, the second one in the
same directory where I have cc1.exe.  Do you have it there?  If not, I
suggest to copy it there, and see if that helps.

> I launch configure script form msys. I already configured msys.bat to
> include mingw-binaries into path, via:
> set PATH=c:\mingw\bin;%PATH%
> in the 1st lines of msys.bat.

I don't recommend doing this: it puts the MinGW binaries ahead of the
MSYS binaries on PATH.  It should be the other way around, because if
you have a MinGW port and an MSYS port of the same executable, you
want MSYS to find the MSYS port first.

(I don't think this issue is relevant to your problem, though.)

Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
MinGW-users mailing list

This list observes the Etiquette found at 
We ask that you be polite and do the same.  Disregard for the list etiquette may cause your account to be moderated.

You may change your MinGW Account Options or unsubscribe at:
Also: mailto:mingw-users-request@xxxxxxxxxxxxxxxxxxxxx?subject=unsubscribe