Web lists-archives.com

Re: [Mingw-msys] HAVE_SETMODE




A follow-up: I've made some progress!

 > > The linking command is:
 > >
 > > gcc -v -g -O2 -o geomorph.exe -Lc:/MinGW/msys/1.0/lib -Lc:/MinGW/lib
                                 ^^^^^^^^^^^^^^^^^^^^^^^^
                                     Bad! No cookie!

Yes.

Most of my problems came from the library conflicts between MSYS and 
MINGW or GTK for linking, and also for defining variables like datadir, 
localedir and so on.

So I've got an almost working program by following these steps, to 
insure that I use mingw/gtk instead of msys when linking and running it, 
from the msys or command.com shell:

1- Check the %PATH%, from which the msys $PATH is initialized ("you 
ensure your $PATH finds the mingw versions first")

2- Check /etc/fstab in MSYS:
C:\MinGW\   /mingw

3-
./configure --prefix=/mingw

4- Reorder appropriately the linking command (e.g. take the former one 
and remove -Lc:/MinGW/msys/1.0/lib).

Now the program does not segfault anymore. It exits on a non-existent 
directory, but I should be able to fix it.

Thanks!

Patrice

------------------------------------------------------------------------------
Special Offer-- Download ArcSight Logger for FREE (a $49 USD value)!
Finally, a world-class log management solution at an even better price-free!
Download using promo code Free_Logger_4_Dev2Dev. Offer expires 
February 28th, so secure your free ArcSight Logger TODAY! 
http://p.sf.net/sfu/arcsight-sfd2d
_______________________________________________
Mingw-msys mailing list
Mingw-msys@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/mingw-msys