Web lists-archives.com

Re: [PATCH 8/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h




On Sun, 2019-06-02 at 00:13 +0530, Deepak Mishra wrote:
> This patch fixes CamelCase blnEnableRxFF0Filter by renaming it
> to bln_enable_rx_ff0_filter in drv_types.h and related files rtl871x_cmd.c
> xmit_linux.c

One could also improve this by removing the
hungarian like bln_ prefix and simplify the
name of the boolean variable.

> diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers/staging/rtl8712/drv_types.h
[]
> @@ -164,7 +164,7 @@ struct _adapter {
>  	struct iw_statistics iwstats;
>  	int pid; /*process id from UI*/
>  	struct work_struct wk_filter_rx_ff0;
> -	u8 blnEnableRxFF0Filter;
> +	u8 bln_enable_rx_ff0_filter;

e.g.:

	bool enable_rx_ff0_filter;

> diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c b/drivers/staging/rtl8712/rtl871x_cmd.c
[]
> @@ -238,7 +238,7 @@ u8 r8712_sitesurvey_cmd(struct _adapter *padapter,
>  	mod_timer(&pmlmepriv->scan_to_timer,
>  		  jiffies + msecs_to_jiffies(SCANNING_TIMEOUT));
>  	padapter->ledpriv.LedControlHandler(padapter, LED_CTL_SITE_SURVEY);
> -	padapter->blnEnableRxFF0Filter = 0;
> +	padapter->bln_enable_rx_ff0_filter = 0;

	padapter->enable_rx_ff0_filter = false;

> diff --git a/drivers/staging/rtl8712/xmit_linux.c b/drivers/staging/rtl8712/xmit_linux.c
[]
> @@ -103,11 +103,11 @@ void r8712_SetFilter(struct work_struct *work)
>  	r8712_write8(padapter, 0x117, newvalue);
>  
>  	spin_lock_irqsave(&padapter->lockRxFF0Filter, irqL);
> -	padapter->blnEnableRxFF0Filter = 1;
> +	padapter->bln_enable_rx_ff0_filter = 1;

	padapter->enable_rx_ff0_filter = true;

etc...

Then you could rename padapter to adapter, and maybe
"struct _adapter" to something more sensible like
"struct rtl8712dev" etc...

And one day, hopefully sooner than later, realtek will
improve their driver software base and help eliminate
all the duplicated non-style defects across the family
of drivers for their hardware...