Web lists-archives.com

Re: [PATCH 2/2] iio: Use __ATTR_NAMED to allow passing name as string to IIO_DEVICE_ATTR_NAMED and change usage to pass string




On Wed, Sep 13, 2017 at 01:26:27PM +0530, Himanshi Jain wrote:
> Add IIO_ATTR_NAMED macro to use __ATTR_NAMED to allow passing name as
> string to IIO_DEVICE_ATTR_NAMED. Change current usage of
> IIO_DEVICE_ATTR_NAMED to pass name as string.
> 
> Signed-off-by: Himanshi Jain <himshijain.hj@xxxxxxxxx>

This version looks nice.  The subject is just *way* too long, though.
Also you have put a v2 in the subject and a little changelog after the
--- cut off.  Just call it something like:
[PATCH 2/2 v2] iio: Change to __ATTR_NAMED()

regards,
dan carpenter