Web lists-archives.com

Cmake error while building lxmlGUI




While I was tring to build the kxmlgui package from the source code. 
I recieved the following error.

I am new to cmake

--  

-- The following OPTIONAL packages have been found:

* KF5Attica (required version >= 5.53.0), A Qt library that implements the Open Collaboration Services API, <https://projects.kde.org
/attica>
  Support for Get Hot New Stuff in KXMLGUI

-- The following REQUIRED packages have been found:

* ECM (required version >= 5.53.0), Extra CMake Modules., <https://projects.kde.org/projects/kdesupport/extra-cmake-modules>
* Qt5Gui (required version >= 5.9.5)
* Qt5Widgets
* Qt5DBus
* Qt5Network
* Qt5PrintSupport
* KF5CoreAddons (required version >= 5.53.0)
* KF5ItemViews (required version >= 5.53.0)
* KF5Config (required version >= 5.53.0)
* KF5ConfigWidgets (required version >= 5.53.0)
* Gettext
* KF5I18n (required version >= 5.53.0)
* KF5IconThemes (required version >= 5.53.0)
* KF5TextWidgets (required version >= 5.53.0)
* KF5WidgetsAddons (required version >= 5.53.0)
* KF5WindowSystem (required version >= 5.53.0)
* KF5GlobalAccel (required version >= 5.53.0)
* Qt5Xml
* Qt5Test
* Qt5 (required version >= 5.9.0)

-- The following features have been disabled:

* QCH, API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)

-- Configuring done
CMake Error at src/CMakeLists.txt:73 (add_library):
 Target "KF5XmlGui" links to target "Qt5::CorePrivate" but the target was
 not found.  Perhaps a find_package() call is missing for an IMPORTED
 target, or an ALIAS target is missing?


CMake Error at src/CMakeLists.txt:73 (add_library):
 Target "KF5XmlGui" links to target "Qt5::CorePrivate" but the target was
 not found.  Perhaps a find_package() call is missing for an IMPORTED
 target, or an ALIAS target is missing?


-- Generating done
-- Build files have been written to: /home/vidu/kde/kf5dependencies/kbookmarks/build/kxmlgui/build