Web lists-archives.com

Re: systemsettings5/Regional Settings - strange choices




On Wednesday, 17 October 2018 00:09:43 BST Peter Humphrey wrote:
> On Tuesday, 16 October 2018 17:17:53 BST Ianseeks wrote:
> 
> > systemsettings5/Regional Setting/Languages
> > I checked this setting and it was blank so i added Brit English. I'm not
> > sure when this changed to blank as i always change everything regional
> > related when the user is created or soon after if any regional issues
> > occur.
> > 
> > systemsettings5/Regional Setting/Formats
> > I set "Region" to UK British English (en_gb). The "Detailed Settings" was
> > disabled. I wanted to change the "measurement units" to metric so I enabled
> > the "Detailed Settings". The "Measurement Units" changed from Imperial to
> > Metric even though the entry said "no change". I then went to change the
> > entry for "Measurement Units" and i was presented with drop the box of
> > country options plus "no change" and "Default" - why is it not just
> > "Metric" or "Imperial"?
> > 
> > The only way i can get metric is to select "no change".
> > 
> > The number format and time display format changed as well
> > 
> > Something i don't understand is that all the places to change the
> > configuration present a list of countries as the options as described
> > above.  Can anyone enlighten me ?
> 
> I don't know whether this might help but I got this output from
> systemsettings5:

Thanks Peter.  I've managed to get the settings as i need but the whole process and config options seem wrong.

> $ systemsettings5
> QCoreApplication::arguments: Please instantiate the QApplication object first
> WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
> WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
> KActivities: Database connection:  "kactivities_db_resources_140259492624064_readonly" 
>     query_only:          QVariant(qlonglong, 1) 
>     journal_mode:        QVariant(QString, "wal") 
>     wal_autocheckpoint:  QVariant(qlonglong, 100) 
>     synchronous:         QVariant(qlonglong, 0)
> Nothing to load - the client id is empty
> Nothing to load - the client id is empty
> org.kde.kcoreaddons: Error loading plugin "kcm_translations" "The shared library was not found." 
> Plugin search paths are ("/usr/lib64/qt5/plugins", "/usr/bin") 
> The environment variable QT_PLUGIN_PATH might be not correctly set
> file:///usr/lib64/qt5/qml/QtQuick/Controls.2/org.kde.desktop/ScrollView.qml:70: TypeError: Type error
> KActivitiesStats( 0x5607de178860 ) ResultModelPrivate::onResultScoreUpdated  result added: "kcm:kcm_translations.desktop" score: 1 last: 1539710576 first: 1537521953
> KActivitiesStats( 0x5607de178860 ) ResultModelPrivate::onResultScoreUpdated  result added: "kcm:formats.desktop" score: 1 last: 1539710590 first: 1537521978
> Wrote script:  "/home/prh/.config/plasma-locale-settings.sh" 
>  "# Generated script, do not edit\n# Exports language-format specific env vars from startkde.\n# This script has been generated from kcmshell5 formats.\n# It will automatically be overwritten from there.\nexport LANG=en_GB.UTF-8\nexport LANGUAGE=en_GB\n"
> Closing SQL connection:  "kactivities_db_resources_140259492624064_readonly"
> 
> Somebody might get a clue from it.
> 
> 


-- 
opensuse:tumbleweed:20181012
Qt: 5.11.2 KDE Frameworks: 5.50.0 - KDE Plasma:  5.14.0 - kwin 5.14.0
kmail2 5.9.1 - akonadiserver 5.9.1 - Kernel:  4.18.12-1-default  - xf86-video-nouveau:  1.0.15