Web lists-archives.com

Re: Lost behavior between KDE 4.1.3.1 and 5.5.5




On Friday June 22 2018 02:20:57 J Leslie Turriff wrote:

>> I would think that Trinity would stick with the
>> latest QT just for support issues.
>	The Trinity team is quite small considering the size of their chosen task; 
>I'm pretty sure they're pedaling as fast as they can.  I don't know the 
>details of their schedule when it comes to QT.

I've already looked at porting KNode from KDEPIM4 to 5. KNode is (was) a fossil leftover from KDE3 and only able to run because of a Qt3 compatibility layer in Qt4. That layer has gone, and if you're not the original author of the code (or someone who understands it quite well as well as the classes that have to be replaced) it can be a very daunting task to port from Qt3 to Qt5.

So if the Trinity team is quite small I wouldn't hold my breath for them to catch up, but I can be wrong of course. In a sense they had enough time during the KDE4 epoch to port KDE3 to native Qt4.

R.