Web lists-archives.com

Re: Dolphin has become very slow after recent update




Bug Reporter posted on Mon, 07 May 2018 19:02:36 -0400 as excerpted:

> Dolphin has become slow recently. In particular, adding or moving a
> bookmark in the Places panel has a delay of several seconds.
> 
> To reproduce, create a new bookmark in Places or move an existing
> bookmark up or down in the Places panel. There is a delay of a few
> seconds.
> Previously, there was no noticeable delay. I now experience these delays
> 100% of the time.
> 
> Just now I timed it and there is a delay of about 5-6 seconds before the
> moved bookmark appears moved, then there is a delay of another second or
> so before Dolphin's GUI is responsive again.
> 
> Also, if I leave Dolphin open all day, even normal navigation from
> location to location also becomes very slow. To reproduce, navigate to
> any location using Dolphin. There is a delay of several seconds before
> Dolphin refreshes to show the new location. During this time the Dolphin
> UI is unresponsive (Dolphin appears frozen briefly). Previously, there
> was no noticeable delay. I only experience this if Dolphin has been open
> for a while. If I close and reopen it, I do not get the very long delay
> when navigating to a new location.
> 
> I'm running KDE on Arch.  Here's some system info:
> 
>    - plasmashell --version: plasmashell 5.12.5 - dolphin --version:
>    dolphin 18.04.0 - Linux 4.16.6-1-ARCH #1 SMP PREEMPT Mon Apr 30
>    12:30:03 UTC 2018 x86_64 GNU/Linux
> 
> The previous time I looked at my version, I had plasmashell 5.12.3 (a
> couple months ago). Dolphin was fine in that version. So the problem
> started after that version, but it may have appeared before my current
> version. I first noticed it several weeks ago. Nothing about my system
> has changed other than normal Arch updates.

As I said in a previous thread, I don't tend to run dolphin that much 
here, so I can't say on the all day open case, but...

At least on the move bookmarks around case, there's no noticeable lag 
here.

I'm actually running live-git (normally master branch) versions of all 
kde-frameworks, all kde-plasma, and most kde-apps, updated every few days 
and just last nite, so it's all current.  FWIW, about dolphin says 
18.07.70, and the libraries tab says frameworks 5.46.0, qt 5.11.0 
(actually 5.11.0 beta4).

So either it's fixed again in current live-git, or perhaps I don't have 
whatever is slowing it down for you enabled, here.  I'm on gentoo, and 
run a pretty lite and lean configuration.  No semantic-desktop/file-
indexing to worry about, no policykit, and no user-triggered auto-
mounting.  So if one of those components is triggering your slowdown, I'd 
not see it as for the most part I disable those at build-time.

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman