Web lists-archives.com

Re: Problem solved ([vlc] Qt4 plugin into Qt5 program)




On Thu, 18 May 2017 22:24:35 +0000 (UTC)
Antonio Rojas <arojas@xxxxxxxxxxxxx> wrote:

> El Thu, 18 May 2017 09:43:48 +0200, René J.V. Bertin escribió:
> 
> > What distros could and should do is ship a VLC built against Qt5 when
> > they provide a Qt5-based desktop environment. Much simpler than running
> > a post-install command properly.  
> 
> That would just reverse the problem: KDE4 applications would crash when 
> using phonon-vlc. Most distros still ship both KDE4-based and KF5-based 
> applications.
> 
I tried the vlc backend early on after installing kde5 for the first time. There was more kd4 about then than now. Since installing VLC 3 the option for a vlc back end has now gone - or that is why I think it's gone. It's using gstreamer 4.9. I did clean out the vlc version that had the problem with the nvidia driver when I un installed it so the backend went with it.

VLC 3 Beta came as a one click install. I think some one put it on packman because of the problem with the nvidia driver. I believe it's directly from git but converted to an rpm - not a job I'd fancy doing myself. I tried to install it from source years ago and got no where pretty quickly.

It looks like the vlc I tried was 2.2.4 along with libvlc5 2.2.4. Not sure about the backend, probably phonon4qt5 but may have been just plain vlc-backend. All done by opensuse of course so may not be of any use to others.

Saw a comment on the web wondering why opensuse put such effort into kde, waste of time etc - response from many - good job they do  and hope it remains primarily a kde distro.

John
-