Web lists-archives.com

Re: Error "The process for the file protocol died unexpectedly." in KDE 5 apps which use KDE 4 libraries




On Friday March 31 2017 16:43:07 Kai Herlemann wrote:

>I'm wondering about that, because the concerned programs are KDE 5
>programs and as far as I know, KDE 4 libraries and programs are
>discontinued.

That's not entirely accurate: a number of applications are still Qt4/KDE4 applications despite being part of "KDE applications 16.x", and that's all the more true for distributions that don't ship the latest KF5 versions. For this reason the KDE4 libraries (KDELibs) are still being maintained to some extent.

>I got that error message at the first time after a upgrade (I'm using
>Debian testing). I tried to solve it by moving

Was that a large upgrade? I've already seen Debian upgrades trickling down in parts with the result of instability (or packages being tagged for removal). In that case the situation usually resolves itself when the upgrade becomes fully available on all mirrors.

If that's not it you'll have to launch the crashing applications under a debugger and see if that gives you a less vague error message (after installing the relevant debug packages if your distribution is organised that way).

R