Web lists-archives.com

Re: "autistic" Konsole




René J.V. Bertin posted on Sat, 18 Mar 2017 09:48:38 +0100 as excerpted:

> I have been running Qt 5 without libinput support built in, I'll rebuild
> now that I have a recent version of that library installed and see if it
> changes anything.

FWIW, I'm running gentoo ~amd64 (translate the ~ as testing), with most 
of kde installed as live-git from the gentoo/kde overlay, so I should be
/reasonably/ current on most things and of course live-git on kde.

While libinput-1.6.3 is installed, my xf86-input drivers don't depend on 
it, only two packages, kwin (live-git) unconditionally, and qtgui-5.7.1, 
conditionally on USE=libinput, which I have disabled so it's not building 
against it.

And obviously I've not encountered any such issues here, either now or in 
the in-memory past, or I'd have posted them by now.

Which indicates that if it's libinput related, it's not common at least 
to the versions I've had installed at the same time.

Tho if you're running libinput-related drivers, it could be related to 
that.

And there's gotta be /some/ reason it's happening, and given the 
situation, this is as good a shot in the dark to test as any other, so 
hope it helps.

Please post any updates.  You got me interested in the outcome, now. =:^)

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman