Web lists-archives.com

Re: Qt 5.6LTS vs 5.7+




René J.V. Bertin posted on Sat, 03 Sep 2016 17:13:19 +0200 as excerpted:

> A bit of a generic development question, I hope this is at least as
> appropriate a place to ask as the frameworks-devel ML:
> 
> Are there any plans or guidelines for requiring features from Qt 5.7 or
> later before the 5.6LTS EOL? In other words, does the fact that Qt 5.6
> is supposed to be a LTS release change anything and, by extension,
> should distributions and distribution systems provide 5.6 and 5.7+
> alongside (as drop-in alternatives or otherwise)?

I'm not a dev, but I do run live-git kde (frameworks/plasma/apps, via 
gentoo/kde overlay) and track the git logs to a reasonable extent, and 
believe I can answer your question based on that.  Tho one caveat, I've 
not updated in ~2 weeks as I'm between homes ATM (city relocation and 
redevelopment project, tho I can't complain at the deal I got, but I'm in 
a hotel at their expense ATM), so while I'm updating today, my current 
info is a couple weeks dated.

Some plasma components in particular already have had commits bumping to 
qt-5.7 minimum.  In some cases they were reverted, but I don't believe 
all of them have been.

I /think/ most frameworks are being a bit more conservative, however, 
allowing stand-alone apps to be able to update frameworks requirements 
while sticking with qt-5.6 LTS minimums.  I hadn't thought about it in 
those terms, but it's possible those were the reverts I saw.

Of course for official policy you'll probably need to wait for a dev 
reply (and Kevin will likely reply as soon as he sees it, as he keeps an 
eye on the lists and answers from a dev perspective when needed).  But 
this is what I've seen running live-git kde as a user.

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman