Web lists-archives.com

Re: [kde] "autistic" Konsole




René J.V. Bertin posted on Tue, 12 Jul 2016 09:43:21 +0200 as excerpted:

> On Tuesday July 12 2016 06:16:30 Duncan wrote:
> 
> Ctrl-S stops terminal output but doesn't cut keyboard input, but yeah, I
> did try Ctrl-Q just in case.
> 
>>So I must ask if you're sure you're opening a new konsole /process/, or
>>just a new thread on the same process.
> 
> About as sure as I can be without having actually verified with `ps`.
> Opening a new window through the menu gives a similarly afflicted
> window, and all already open tabs lost their keyboard input yesterday.
> IIRC the symptom was more tab-specific with Konsole4 (ie only a single
> tab at a time would be affected and I could use "New Tab" or "Clone Tab"
> to escape from the issue.

So opening a new window via the menu gives you a similarly afflicted 
window.  But that doesn't mention how you're opening a new konsole window 
that you believe is in a new process, that's free of the problem.

(I'd try to verify different process or not, here, if I knew how you were 
doing it.)

> I've also tried to toggle the keyboard layout to and from a different
> language. That particular action tends to help me when KDE apps drop the
> "dead" aspect from the dead key I use to get accented letters
> ("Macintosh" keyboard layout, Alt-Gr serves as a deadkey such that
> AltGr+e,e gives an é). That particular symptom may be KDE PIM trying to
> switch my keyboard when it detects a language setting in an email, I
> realise now.


Good idea.

BTW, do konsole hotkeys still work?  I'd assume so, but...

>>Does the problem occur when you type into a text-VT login outside of X
>>--
>>IOW when you're not using a terminal window, but an actual (virtual)
>>terminal?  What about when you try some other x-based terminal emulator
> 
> I cannot say as I have yet to figure out how to trigger the issue.

So it's not happening regularly enough to be sure when typing in a text 
VT login.  You just know it happens occasionally in a konsole window.

>>Does konsole's clear scrollback and reset (view) menu function do
>>anything?
> 
> Other than clear the screen, nothing.

OK, probably not a terminal-control escape sequence after all.

>>have the same issue, the problem is almost certainly that you're
>>accidentally engaging some terminal-control escape sequence, and the
>>emulation is then expecting a color-set sequence, for example.
> 
> It's possible, though it's surprising that I'm only discovering that
> now. I've been using tcsh since the 90s, and Konsole for years too...
> 
> Thanks for brainstorming with me anyway.

You're welcome.  I want to find out the problem too, now, in case I come 
across it as well.  =:^\  (FWIW, I'm running mostly kde, including both 
frameworks and plasma, along with some but not all of the individual 
apps, from git.  Tho I've been too busy to pull and update for a couple 
weeks now as I just bought a house.  But unless you're running /real/ new 
or live-git kde as well, I'm very likely running newer code, which for 
all I know wouldn't be affected.)

I think I'd try xterm here, and see if it was affected, or take it as an 
opportunity to google up terminal app reviews and try some other one that 
looked interesting.

Oh, I'm assuming it'd be affected as well as it's mostly the same konsole 
kpart-based code, but have you tried the terminal minicli in kate or 
dolphin?  Without an easy reproducer it might be frustrating to work in 
the limited space offered by those for long enough to try to trigger it, 
but knowing whether "non-konsole konsoles" exhibit the same issue would 
be another data point.

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.