Web lists-archives.com

Re: [kde] Mapping physical screens to KDE containments




Martin Steigerwald posted on Mon, 11 Apr 2016 16:18:39 +0200 as excerpted:

> On Montag, 11. April 2016 10:01:36 CEST Duncan wrote:
>> Felix Miata posted on Sun, 10 Apr 2016 23:06:01 -0400 as excerpted:
>> > Nick Coghlan composed on 2016-04-11 12:42 (UTC+1000):
>> >> Using a multi-monitor setup under Plasma 5 (Fedora 23), I have a
>> >> problem where the configured panel applet will disappear and not
>> >> come back if an external monitor is reconfigured to clone the laptop
>> >> monitor, and then switched back to being an independent screen.
>> > 
>> > Looks like you must have found the explanation why I have a whole
>> > bunch of F23 and F24 installations in which I never see a panel any
>> > more. I'm never using a laptop, but I do have several multi-output
>> > gfxcards to which I only sometimes connect more than one display.
>> > When I do, it's always in an extended desktop mode configured
>> > manually either using xrandr or xorg.conf*
>> > via /etc/X11*.
>> 
>> A similar problem here, tho on a triple-monitor setup with a permanent
>> layout configured in xorg that plasma would ideally simply leave
>> alone... only it doesn't.
> 
> Well multi monitor support in Plasma with X11 still has a lot of issues.

Rather an understatement.

Anyway, I seem to have found a much simpler workaround, at least for me 
(with the same hardware always connected, just coming back in a different 
order after screen blanking and automatic TV/monitor power-off).  I just 
have to remember to do it every time.

The simple workaround?

Before turning on the two TV-monitors (which must be turned back on, 
unlike the actual computer monitor), I switch VTs to a non-X CLI login 
VT, and turn on the TV/monitors when I'm at the CLI login.  When 
everything's back on and displaying the same CLI VT, I can switch back to 
X/plasma, login at the screen-locker if necessary, and when the screen-
locker clears (if it was active), everything's in the same place it was 
when I went idle and the screen-blanking kicked in.

Apparently because I'm not on the X/plasma VT when I turn on the TV-
monitors, and the CLI clones the same thing to all three, the CLI gets 
the plug event then and it doesn't matter.  Then when I switch back to X/
plasma, it's a VT switch event, not a plug event, and since the same 
hardware is attached (and it actually sees it as the same hardware), it 
uses the same layout.

While I've not been running with this workaround for long enough to be 
sure it always works yet, it has worked reliably, several times now, 
including yesterday when I deliberately left the system running when I 
left for work (short work day), and came home to try it after ~6 hours.

The only thing is I have to remember to switch to a CLI VT before turning 
the TV-monitors back on.  Tho that's not /so/ difficult, as I do have to 
actually turn them on; I can't simply wiggle the mouse or whatever and 
have them come back on as the actual computer monitor does.  So assuming 
it continues to work reliably, I just have to make switching VTs part of 
my monitors turn-on routine, and once that becomes part of the same 
habit, I'll be good to go.

I think I can get the current state from xrandr output or the like...  
Maybe I can create a script that runs in the background to query that, 
and auto-switch to a CLI VT when the screen blanks or the TV-monitors 
turn off, and back after they turn on?  That could automate the 
workaround...

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.