Web lists-archives.com

[kde] plasma-desktop-5.5.2: LayoutManager.js (and other *.js files) not found.




Trying to upgrade from kde4 to plasma5 on gentoo.  I've been trying it 
every few months for a couple years now and have in general been getting 
further each time, but haven't actually gotten a working plasma5 system 
yet, so keep having to revert to kde4.

Since I have a working kde4, and various files from frameworks5 and 
plasma5 collide with and thus their packages block their kde4 variants, 
I'm trying for a minimal plasma5 install at first, with all the minimal-
desktop-set dependencies that do *not* trigger blockers kept pre-
installed and upgraded to current for easy tests when I have time to kill 
kde4 for a bit so I can install and test the latest plasma5.  
Unfortunately, as I said, so far I've had to revert to kde4 to get an 
actually working desktop back every time, but I'm making progress.  Once 
I actually get the minimal install working, I plan to upgrade an app at a 
time to the plasma5/kde-apps5 versions, starting with the kde control 
panel or whatever they're calling it in plasma5, so I can set basic 
colors, widget themes, etc, then doing konsole and etc, configuring as I 
go.  But so far I've not yet gotten even a basic plasma5 desktop going, 
so have always had to revert to kde4 to get a working desktop again, tho 
I'm almost getting a working desktop, now (and do with the workaround).

So last nite I tried again... and got further than ever before, but again 
had to revert.  Here's where I got stuck last nite, and what I'm posting 
now to see if someone can help me figure out what's going on and how to 
fix it properly -- I already have a workaround, but it'd involve a lot of 
manually created symlinks pointing at the "misplaced" files for a lot of 
packages, and while I'd do it for just a couple, I don't want to do mass 
symlinking workarounds as I'd need here, in part because I'd have to 
track and eventually undo it, when things get fixed and I update.

The install went fine, and logged in at the CLI shell prompt as my normal 
user, I moved both ~/config (aka ~/.config, I've set the appropriate XDG 
var and symlinked the dot-dir to the unhidden version, as I don't like 
dealing with hidden dirs like that, particularly major ones) and ~/kde 
(~/.kde) out of the way so when I first started plasma5, I'd get a clean 
config to start with.

Then I did my usual startx with kde/plasma as the xsession, and X started 
fine.

But while plasmashell started and I got the very beautiful (blew me away, 
actually, it's the most awesome default wallpaper I've seen!) shipped-
default multi-color plasma background...

I had no nice plasmoid widgets!  Instead, I see this text message printed 
on the background:

Error loading QML file:
file:///share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/
main.qml:32:1:
Script
file:///share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/
LayoutManager.js
unavailable
file:///share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/
LayoutManager.js:
File not found

(Yes, that's /share/ not /usr/share on my system as I've done the /usr 
merge as a symlink: /usr -> . , so all the usual subdirs of /usr, 
including /usr/share, end up directly on / .)

And only the error icon beside the message actually lets me context-click 
to get the standard desktop context menu.  Everywhere else on the 
desktop, it just gives me a default cut/copy/paste/etc context menu.  
Well, except for the "pancake" menu icon (that replaced kde4's cashew) in 
the corner.  It still works, but doesn't offer a way to start anything, 
etc, so the only launcher I have (besides the default alt-F2 or alt-F3, 
whichever it is, runner) is in the context menu for that error icon.

So I try adding some plasmoid widgets like analog clock, etc, and at 
first they won't drop on the desktop, because the desktop containment is 
missing a file and can't run.  After the workaround below, I got a 
desktop containment and the plasmoids would drop on it, but most of them 
immediately displayed a similar error, which after verifying a few, I 
gave up with the workaround, quickly realizing that I'd be having to 
manually symlink probably dozens of files were I to keep going as a 
workaround.

I could add a default panel, but it had the same problem, nothing but a 
big missing file error printed across it.  After trying the workaround 
below, while the digital clock worked and the task area showed windows, 
and the launcher opened up it launcher menu, clicking on the pager opened 
another missing file error dialog.


But... the funny thing is, all the missing files are of the pattern 
/share/plasma/plasmoids/*/contents/ui/*.js.  And all the files are 
actually there... as /share/plasma/plasmoids/*/contents/code/*.js.  IOW, 
they're in the contents/code subdir, while the plasmoids are looking for 
them in the contents/ui subdir!

Just to see if the immediately obvious workaround worked, I tried a 
couple of symlinks in the ui subdirs, LayoutManager.js -> ../code/
LayoutManager.js, one each for the desktop containment and the panel, 
then restarted activitymanagerd and plasmashell, and sure enough, the 
desktop and panel worked, then.  But while some plasmoids worked, others 
failed with similar missing file errors, only now utils.js, logic.js, 
etc, instead of the LayoutManager.js errors I was getting for the 
containments. 

Once I realized it wasn't just the containments, but a good share of the 
plasmoids with the problem as well, I gave up and after filing a bug with 
gentoo, reverted to kde4, as I didn't want to manually symlink ALL of 
them.


So here's the gentoo bug link, altho it says most of the same stuff I say 
above, just adding gentoo-specific stuff like emerge --info for the build 
environment, etc.

https://bugs.gentoo.org/show_bug.cgi?id=570210

As in the title, the affected package owning those files is plasma-
desktop, version 5.5.2, in this case still in the gentoo/kde overlay as 
it hadn't moved to the main tree yet.  Installed kde-frameworks version 
is 5.17.0-r2 (the -r2 indicating the gentoo specific package bump on 
upstream 5.17.0).  Installed qt5 is qt 5.5.1.  Both of those are from the 
main gentoo tree.



Now the reason I posted it here too, while I wait for an answer there:

Obviously, people must be successfully running it.  Are their 
LayoutManager.js files installed in the code subdir or the ui subdir?  If 
it's ui, then the bug is in the gentoo package installing them to the 
wrong subdir.  If it's code, then the bug must be in whatever SHOULD be 
telling plasma/qml to look in the code subdir as well as ui, as it's 
simply not happening here, for some reason or other.  (I looked at the 
code in the main qml files, and they simply import the missing files by 
name, not supplying path, but what configures the paths import looks in 
to try to find them?)

Assuming it's a bad config setting, right here is where it'd be nice to 
have Kevin (KDE dev who often posts to these lists) step in and explain 
how that's configured and/or what package I might be missing. =:^)  
Thanks in advance to him or anyone else who can explain that well enough 
to help me fix it locally, either by manually setting up the missing 
config, or figuring out what package I'm missing so I can install it. =:^)


I already tried to google it, but my google foo failed me on this one.  
Either I get a bunch of irrelevant generic hits (for just 
Layoutmanager.js), or I get plasma-specific stuff but it's mostly package 
contents listings and the like, or if I try putting specific bits of the 
error in quotes, I end up with nothing.  So I guess google hasn't seen 
this specific error either, yet, or at least my google foo wasn't good 
enough to turn it up if so.  With some luck, google will index this post 
and at least other people with the error will find someone else had it, 
even if nobody posts a good solution.  And with even more luck, someone 
will actually have the solution, both for me, and for others who google 
the problem later to find. =:^)


Meanwhile, kde4 continues to work fine, once I toggle back to the kde4 
versions of the blocker packages and move my kde and config dirs back in 
place. =:^)  So I either get this fixed, or wait another few months and 
try again, hopefully getting past this problem to by then, and getting an 
actually working plasma desktop.  At least I'm close enough now I can get 
it with workarounds, tho other than that fantastic multi-colored 
wallpaper, as usual I'm not all that thrilled with the default color 
scheme, widget style, etc, and that'll be first up on my list to change 
once I get the basics working well enough that I can start working on 
plasma5 customization, instead of just getting it to actually /work/.

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.