Web lists-archives.com

Re: [kde] kmix looks broken




On 12/05/14 02:40, Duncan wrote:
Meanwhile, for some time kmix has been acting up here.  I can't restore
it /or/ get the master-volume popup from the tray icon, and when I try to
restore, nothing appears and alt-tab, etc, go haywire.  I have to click
in an app to activate it (even if it still shows as active, and the
normal focus-follows-mouse... doesn't), before I can alt-tab or get the
plasma panel to popup or focus-follows-mouse working again.

But (1) I can still use the kmix tray icon for mute/unmute (which is
generally all I use it for anyway, since I have the sound patched to my
home 5.1 system where I control volume, etc), and...

(2) If I open a konsole and killall kmix, then run kmix twice, (the first
one going in the tray again after the killall), *THEN* I can get the kmix
window to show.

This is on kde 4 git-master updated as of a few days ago, reporting as
4.13.60, using the gentoo/kde overlay and 4-master ebuilds (4.9999).

I'm on Gentoo too (~amd64) with KDE 4.13.0. I also can't the kmix window to show. Right-click and selecting "restore" just pops up the usual non-windowed panel-thingy that you get when simply left-clicking on the tray icon.

Running KMix though (either from the K-menu or a terminal) brings up a normal KMix window though without me having to kill the current kmix process first.

___________________________________________________
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.