Web lists-archives.com

Re: [kde-linux] how to get kde applications version with commandline




On 29/02/16 12:56, Vojtěch Zeisek wrote:
Dne So 27. února 2016 03:56:06, yahoo-pier_andreit napsal(a):
I'm using opensuse leap 42.1 and I would like to have a way to know kde
applications version using commandline.
how Ican get this??

As You are on openSUSE, try using openSUSE package manager zypper:
zypper se -si PackageName
* se or search for searching
* -s for printing details
* -i only for installed packages
As package name try any of konsole, kate and so on...
HTH

manythanks, I tried it, but, it takes time and involve all the repositories...., is not useful for what I want to do, like for example have a plasmoid to show kde applications version and other fast checks :-) :-)

pla@suseST-pla:~> zypper se -si kate
Repository 'Google (chrome)' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'KDE:/Frameworks5/openSUSE_Leap_42.1' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'nVidia Graphics Drivers' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'Packman Repository' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'KDE:Extra' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'openSUSE-Leap-42.1-Update' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'openSUSE-Leap-42.1-Update-Non-Oss' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'repositories/Emulators:/Wine/' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'repositories/GNOME:/Apps' is out-of-date. You can run 'zypper refresh' as root to update it. Repository 'wolfi repo for leap 42.1 with KDE4 (to have KDE4 in leap 42.1)' is out-of-date. You can run 'zypper refresh' as root to update it.
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+------------------------+---------+--------------+--------+---------------------------------------------------------------
i | ghc-highlighting-kate | package | 0.6-1.1 | x86_64 | openSUSE-Leap-42.1-Oss i | kate | package | 4.14.3-3.3 | x86_64 | wolfi repo for leap 42.1 with KDE4 (to have KDE4 in leap 42.1) i | kate-plugins | package | 15.12.3-15.4 | x86_64 | openSUSE-Leap-42.1-Update i | kate-python-plugins | package | 4.14.3-3.3 | x86_64 | wolfi repo for leap 42.1 with KDE4 (to have KDE4 in leap 42.1) i | kate4-parts | package | 4.14.3-2.3 | x86_64 | openSUSE-Leap-42.1-Oss i | libkate-devel | package | 0.4.1-23.1 | x86_64 | openSUSE-Leap-42.1-Oss i | libkate1 | package | 0.4.1-23.1 | x86_64 | openSUSE-Leap-42.1-Oss i | libkatepartinterfaces4 | package | 4.14.3-2.3 | x86_64 | openSUSE-Leap-42.1-Oss i | liboggkate1 | package | 0.4.1-23.1 | x86_64 | openSUSE-Leap-42.1-Oss
pla@suseST-pla:~>
___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.