Web lists-archives.com

[kde-linux] Shutdown/Logout/Restart problems with KDE/Plasma5




When I go to use the logout/shutdown/restart buttons in Plasma 5, the computer does not take the action requested.

A message in the style of

Shutdown called with confirm  -1  type  2  and mode  -1

is appended to ~/.xsession-errors each second (approximately, I didn't time it).

qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout x y z

with x, y, z some integer (not just the values allowed) does the same, and the log reflects the values passed.

In this case, at the time of the request, but only once, the ~/.xsession-errors shows also

kf5.kinit.klauncher: appId= ":1.49" newAppId= ":1.49" pendingAppId= "*.polkit-kde-authentication-agent-1"
kf5.kinit.klauncher: appName= "49"

I don't have systemd.
ConsoleKit is build from a revision somewhere around 0.9.2 from the ConsoleKit2 github repository, and running ck-list-sessions returns two sessions, such as:

Session3:
       unix-user = '1000'
       realname = 'Christian'
       seat = 'Seat1'
       session-type = ''
       active = TRUE
       x11-display = ':0'
       x11-display-device = '/dev/tty7'
       display-device = ''
       remote-host-name = ''
       is-local = TRUE
       on-since = '2015-07-08T08:36:30.639138Z'
       login-session-id = '6'
Session2:
       unix-user = '1000'
       realname = 'Christian'
       seat = 'Seat3'
       session-type = ''
       active = FALSE
       x11-display = ':0'
       x11-display-device = ''
       display-device = ''
       remote-host-name = ''
       is-local = TRUE
       on-since = '2015-07-08T08:36:28.901189Z'
       login-session-id = '6'

It can be seen that one is TRUE/TRUE, whilst the other is FALSE/TRUE, which seems reasonable. Playing with files in /etc/pam.d/{sddm,sddm-greeter} or /usr/share/sddm/scripts/Xsession can change these, but they tend to become more problematic/messy, rather than less.


Any ideas what I could look into to try and fix this?

Possibly related, although maybe not:
InputActions doesn't run on startup, despite being selected. Several other startup services behave similarly. I found a text file that confirmed this, although I can't now find it again.

Some reports of similar issues suggested that the problem might lie in the ability to play .ogg sound files, such as /opt/kde/share/sounds/Oxygen-Sys-Log-Out.ogg. Although I did have some problems playing this (and other) sound file(s), I have since managed to fix that up by some combination of installing KMix, adding 'load-module module-device-manager' to the bottom of /etc/pulse/default.pa and adding the plasma-volume-control in Harold Sitter's scratch repository. Sound files (including the Log-Out.ogg) now play fine.

Best,
Chris
___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.