Web lists-archives.com

Re: [kde-linux] Latest ktorrent






On 06/15/2015 01:03 AM, Duncan wrote:
jd1008 posted on Sun, 14 Jun 2015 16:36:57 -0600 as excerpted:

OK,
so I did find the how-to-build   simple instructions.
I installed all the required packages and ran cmake in the build dir,
and that worked just fine.

Ran make and it belched the following error:


[  3%] Building CXX object src/CMakeFiles/ktorrent.dir/util/functions.o
/usr/src/redhat/NON-RPM/network-apps/ktorrent/libktorrent-1.3.1/src/
snip ...
However, 1 argument library function vs. 2 provided by caller looks like something that should always be a problem, so I doubt that's it.
gcc-4.4.7-11.el6.x86_64


2) What version of whatever package owns /usr/include/kde4/klocale.h ?
# rpm -q --whatprovides /usr/include/kde4/klocale.h
kdelibs-devel-4.3.4-23.el6_6.x86_64

3) If you know how to check (or can figure out), does that package patch
that file in any way?
Well, it seems to.
# rpm -ql --provides kdelibs-devel-4.3.4-23.el6_6.x86_64 | grep klocale
/usr/include/kde4/klocale.h


Seems there's a basic function calling incompatibility between the
library supplying that function, and what the libktorrent sources are
wanting.  It's very likely either a version incompatibility that there's
a patch for, or your package provider patched it and a compatible patch
needs applied to libktorrent.


FWIW, a quick look here says:

a) gentoo doesn't patch libktorrent (same version, 1.3.1).

b) gentoo uses the path /usr/include/klocale.h (no kde4 subdir here), and
that file belongs to kdelibs.

c) I currently have kdelibs-4.14.9 installed.  That should be pretty new
from upstream, as gentoo/kde is pretty much on the ball.

d) gentoo does patch kdelibs, but none of the patches include the word
klocale.h, so that file isn't patched.

e) In my kdelibs-4.14.9 version of klocale.h, I see two definitions for
formatByteSize.
# locate klocale.h
/usr/include/kde/klocale.h
/usr/include/kde4/klocale.h



Personally, if you're on a kde4 earlier than 4.5 as it seems you are,
while the latest 4.14.x with 4.11.x workspace, I'd *VERY* *STRONGLY*
recommend upgrading to at *LEAST* 4.5, as from my experience, despite
Canot - due to the fact that I would want all kde apps to come
from the same repo that provides latest kde4. I do not
know of such a repo for centos.

___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.