Web lists-archives.com

Re: [kde-linux] Build failure: kde-workspace-4.10.3




James Tyrer posted on Tue, 18 Jun 2013 07:09:25 -0700 as excerpted:

> KDE WorkSpace-4.10.3 fails with this error:
> 
> /usr/src/kde-workspace-4.10.3/plasma/generic/scriptengines/
google_gadgets/ggl_package.cpp:244:37:
> error: cannot allocate an object of abstract type 'GadgetBrowserHost'

AFAIK the google-gadgets code is depracated as the gadgets aren't 
supported any longer by google themselves.

I just got thru building and trying (and reverting from due to a serious 
issue) 4.10.80 aka 4.11-beta1 here on gentoo, and due to gentoo/kde 
deciding I needed another hole in my head or some such, in the form of 
mandatory semantic-desktop on gentoo now, I did quite some patching of 
the new gentoo ebuild scripts in ordered to be able to continue to kill 
the semantic-desktop monster.  One of the diffs I processed (and left as 
it was since it didn't pertain to my interest) was the google-gadgets 
option for some package or another.  Thus my personal knowledge of the 
subject, altho I wasn't surprised as I had read about google killing 
google-gadgets some months ago.

So given it's unlikely to be of use any longer anyway, I'd say disable 
the option entirely... which is probably why I've not run into that issue 
here, since I never had it enabled in the first place.

If you'd like, I can track down more specifics about the option...

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.