Web lists-archives.com

Re: [kde-linux] Kde-runtime-4.8 Build issues




James Tyrer posted on Sun, 10 Jun 2012 18:46:43 -0700 as excerpted:

> I recently upgraded my GLibc to 2.15 and as a result, my KDE-Runtime
> module will no longer build.  The cause appears to be changes to the
> "rpc.h" header.  It appears to build fine against older headers.
> 
> BLFS has posted a small patch [attached]:
> 
> http://www.linuxfromscratch.org/blfs/view/svn/kde4/kde4runtime.html
> 
> to make it build with current headers, which I would suggest be
> committed to the GIT repository.

FWIW, glibc-2.15 (gentoo -r2) here, and I've built both kde 4.9 betas 
against it.  I haven't checked patches yet but I doubt gentoo/kde patched 
the beta builds, tho gentoo/tool-chain has obviously patched glibc a bit, 
thus the -r2.  But having not checked those patches I'm not sure they're 
relevant here anyway.

The point being, at least the 4.9 betas are building against glibc-2.15 
here, so a patch has been applied somewhere.  I don't know what version 
of kde-runtime you're attempting to build, but it does seem likely 
they've already patched master/HEAD.  But perhaps not 4.8-branch.

If you'd like me to do more than report that it's working here, I can 
investigate further, but I'm not sure it's worthwhile ATM.  Ask if you 
need it (tho my schedule's not well settled for the next month and I'm 
having hardware issues so I may or may not get back to you)...

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.