Web lists-archives.com

Re: [kde-linux] 'Fetch Error' on exit




On Tue, Feb 7, 2012 at 6:56 PM, Duncan <1i5t5.duncan@xxxxxxx> wrote:
> Mark Knecht posted on Tue, 07 Feb 2012 09:46:27 -0800 as excerpted:
>
>> After updating to KDE-4.7.4 one of my machines, when exiting KDE at the
>> end of the day during a shutdown, so KDE is gone but X hasn't shut off
>> yet, I'm now seeing a black background with a dialog window that just
>> says :
>>
>> 'Unknown error'
>>
>> The title on the dialog box says only 'Fetch job error', or at least
>> that's my guess. The box is not resizable and I cannot see anything to
>> the right off 'err..'
>>
>> From Googling around it seems to be a moderately common problem.
>> Generally people seem to think it points at akonadi which I guess is
>> some sort of database or something like that. Some folks suggest
>> deleting old stuff that uses the database will fix it but knowing what
>> that things those might be eludes me at this time.
>>
>> It's interesting to me that this error does not occur if I just start
>> KDE and immediately exit so apparently it has to do with things KDE does
>> as the day progresses.
>>
>> 1) Is anyone else seeing this?
>>
>> 2) What sort of things do I need to clean up to get rid of this error?
>>
>> 3) Is there some place where KDE logs messages about what it does all
>> day long?
>>
>> The machine is Gentoo based, mostly stable, and has run KDE for a couple
>> of years since it was built.
>
> Gentooer here, too! =:^) ÂBut I'm running a generally ~amd64 system with
> the gentoo/kde overlay and currently the latest kde release, 4.8.0.
> FWIW, I also ran the 4.8 prereleases, betas 1 and 2 and rcs 1 and 2
> (versions 4.7.80, 4.7.90, 4.7.95 and 4.7.98, IIRC). ÂSimilarly, I'm
> running a direct Linus upstream git kernel, currently 3.3.0-rc2-172-
> g23703f8, gcc-4.6.2, binutils-2.22.52.0.1, portage-2.2.0_alpha85,
> grub-1.99, live-git openrc-9999 updated every few days, etc, all of which
> are either package.keyworded ** or package.unmasked in ordered to merge
> them. ÂSo I'm definitely running somewhat ahead of many of your packages,
> including kde.
>
> FWIW, I got fed up with akonadi, however, and unmerged all of kdepim in
> ordered to be able to unmerge it. ÂWith it unmerged, I was able to set
> USE=-semantic-desktop, etc, so I have all that turnakonadied off as
> well. ÂYou'd be AMAZED at how much faster kde runs now! ÂI know I was --
> it was like an MSWormOS user finding out how much either the malware or
> the malware scanners had been slowing him down or like getting a free
> half-gigahertz or another couple cores CPU upgrade! ÂI was /reasonably/
> happy with kde4 before, but now I'm MUCH happier with it! =:^)
>
> However, kmail, akregator, korganizer, knode, kaddressbook, etc, are part
> of kdepim and thus pull in akonadi, so if you use any of them you'll have
> to switch to something else if you decide to go the no-akonadi and
> possibly no-semantic-desktop route, as I did. ÂFWIW, I ran kmail and
> akregator, but switched to the gtk-based claws-mail for both. ÂGiven the
> decade-plus of mail archive I have, the conversion wasn't fun, but it
> wasn't much worse than the conversion from pre-akonadi kmail1 as found in
> kdepim-4.4, to akonadi-based kmail2 as found in kdepim 4.6+.
>
> I haven't seen that error, but since I switched to claws-mail and unmerged
> all kdepim and akonadi before kde 4.7.1 (I was off of kmail for 4.7.0 but
> was still using akregator so couldn't unmerge akonadi until I could
> switch off akregator as well), if it's an akonadi issue, I'd not expect
> to.
>
> What is akonadi? ÂIt's the common database middleware that all of kdepim
> is gradually converting to use. ÂIt can actually use one of several
> database backends, including mysql (the original default) and sqlite (the
> newer default). ÂThe first kdepim app converted was kaddressbook, with
> kdepim 4.4. Âkmail was next, but that was a major project, so there was
> no kdepim 4.5, and kdepim 4.6 was released with the converted kmail2, but
> not considered stable or released in version sync with the rest of kde
> sc. ÂWith 4.7, kdepim synced with the rest of kde sc again, but on gentoo,
> it remains possible to run current kde (thru 4.8.0 at least) with the old
> kdepim 4.4.x and thus the old unakonadified kmail, since the akonadified
> kmail2 is still problematic for many people.
>
> But upstream kde/kdepim are no longer updating the older 4.4.x version,
> so it'll gradually get more and more difficult to keep it working with
> current kde, until various distros decide to drop it. Âgentoo/kde is
> keeping the old kdepim 4.4 for use with kde 4.8, only because they've
> seen no major issues with it that they hadn't already worked thru for
> 4.7, but eventually, there will be issues and gentoo/kde isn't going to
> put a lot more effort into fixing them, so whenever they come up, you can
> expect gentoo to drop the old kdepim 4.4 series.
>
> Meanwhile, with kmail2 as it's found in kdepim 4.6+, it's now akonadi
> that does all the mail fetches, etc. ÂPresumably, it's one of those jobs
> that's failing, leaving the dialog box behind. ÂOf course, that's
> assuming that everybody's guess about what that box belongs to, akonadi,
> is correct...
>
> Personally, given that I've already stated that I switched off of kmail
> and dumped all of kdepim as I simply didn't find the akonadified version
> worth the trouble any more, it should be obvious that's what I
> recommend. ÂI also expect you'll be quite pleasantly surprised at how
> much faster kde is if you kill akonadi and friends, especially if you
> take the opportunity to kill semantic-desktop at the same time.
>
> And I can also say that I've been very happy with claws-mail as a
> replacement, altho the conversion wasn't particularly easy.
>
> But of course, all that is up to you. ÂIf despite that dialog, you're
> finding that the akonadified kmail, etc, is working well for you, as it
> surely will for some people, by all means, go ahead and keep using it, if
> you wish. ÂBut if you've thought about trying something else out, now's
> the time to do it.
>
> --
> Duncan - List replies preferred. Â No HTML msgs.
> "Every nonfree program has a lord, a master --
> and if you use the program, he is your master." ÂRichard Stallman
>
> ___________________________________________________
> This message is from the kde-linux mailing list.
> Account management: Âhttps://mail.kde.org/mailman/listinfo/kde-linux.
> Archives: http://lists.kde.org/.
> More info: http://www.kde.org/faq.html.

Duncan,
   Thanks. It's an interesting story.

   In my case I'm not looking to maintain my own version of KDE here.
I just wanted to know if anyone had seen this problem and what the
solution to fix it was.

   I started going through equery depends ... command looking for what
depends on what and at this point I'd likely be better off to just
create a new user account, see if that account has the problem, and if
it doesn't then just use that. On the other hand I haven't read all
the responses yet so I'm still hopeful someone knows the real
solution.

Thanks again,
Mark
___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.