Web lists-archives.com

Re: [kde-linux] Building KDEPIM 4.7 from the GIT repository




James Tyrer posted on Wed, 21 Dec 2011 15:30:31 -0700 as excerpted:

> On 12/20/2011 09:35 PM, Duncan wrote:

>> You know how to frustrate a person, don't you? =:^(  You mention the
>> old compiler that was broken with the code was a bit old, and that the
>> new one isn't broken, but not a hint to be seen about what the actual
>> version was of either one!<grr!>
>>
> I was still using 4.4.4 and have now upgraded to 4.5 (BLFS was up to
> 4.5.1).  I suppose that I could upgrade to 4.5.3 now that I have gone
> through a major problem with upgrading ppl, cloog, gmp, mpfr, & mpc --
> they need to be built with the current compiler and the compiler needs
> to be be built with the current build -- not a circular dependency, but
> still circular.

FWIW back in the kde-4.6 era gentoo set the minimum required gcc version 
for kde to gcc-4.4 (bug in kdegames at that point, since fixed upstream 
as the BSDs needed it as they were running older gcc), but 4.4's was 
fine, .  Maybe it'll end up needing bumped again. <shrug>

It is a bit difficult to see if gentoo has any related bugs or patches, 
since they've split kdepim into the individual packages, several of which 
mention the messagecomposer dir, so I don't know which package to search 
for bugs or patches.

Meanwhile, thanks for the gcc version numbers.  I'm not so frustrated 
now! =:^)

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.