Web lists-archives.com

Re: [kde-linux] Konqueror and svg web pages.




john Culleton writes:

> On Fri, 9 Dec 2011 21:42:27 +0000 (UTC)
> Duncan <1i5t5.duncan@xxxxxxx> wrote:
> 
> > Dale posted on Fri, 09 Dec 2011 13:33:18 -0600 as excerpted:
> > 
> > > john Culleton wrote:

> > >> Well, it tried but the rendering was faulty. I have some text
> > >> along a curve that Konqueror shows at the top of the page almost
> > >> entirely cut off and of course not on the curve. And some labels
> > >> in boxes were misaligned.
> > >>
> > >> If you go to the url listed below and try it in Firefox followed by
> > >> Konqueror (or vice versa) you will see quite different renderings.
> > >>
> > >> http://websitedesign.wexfordpress.net/index.svg
> > 
> > > I got a 404 error.  Bad link maybe?
> > 
> > Same here.  Over your bandwidth quota for the month, maybe?
> > 
> Bad url. Sorry about that. Try this one:
> 
> http://http://webdesign.wexfordpress.net/index.svg

Getting close :) This works:

http://webdesign.wexfordpress.net/index.svg

Firefox renders this as it should, I guess. So does Opera. In Chromium,
the red text is shifted to the left, and the first character is partially
outside.

Konqueror displays it as you described. But you can change View -> View
mode (or something like that, translating from German here), it's set to
SVG component as default. When set to WebKit, it renders like Chromium
does. And with KHTML you get another weird effect, see for yourself :)

	Wonko
___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.