Web lists-archives.com

Re: [kde-linux] "Dir Filter" has gone missing in 4.7.3 +




James Tyrer posted on Wed, 16 Nov 2011 22:37:17 -0700 as excerpted:

> When I open Konqueror to a directory, there is no filter icon or filter
> window.
> 
> So, I went to "Settings -> Configure Toolbars" and I find:
> 
>      Extra Toolbar <DirFilter>
>      Filter Toolbar <DirFilter>
> 
> I note that the 2nd one is WRONG.  It should be:
> 
>      Location Toolbar <DirFilter>
> 
> But, I don't think that that is the issue here.  The problem is that
> when I open the dialog box for either of these that the only thing
> listed is:
> 
>      --- separator ---
> 
> The icon and the window are not listed.
> 
> Perhaps I made an installation error, or changed something in my user
> tree for 4.6.x, so I tried a new test user and had the same problem.
> 
> Does anyone (e.g. Duncan) have any idea what the problem is.  This
> worked fine with 4.6.x.

I can confirm the same behavior here (4.7.3).  However, I don't have 
every bit of kde installed and don't use konqueror much any more.  Imostly 
kept it installed to use as a second browser, when firefox breaks or I 
want to compare page-display, so I wouldn't be able to tell you when the 
filter functionality broke.  (As a file manager, I tend to use mc in a 
konsole window for most things, along with gwenview for image and video, 
and dolphin works well enough in its role of glorified file dialog, so I 
rarely have a use for konqueror in file management mode at all, except 
for questions such as this.  I tend to switch to mc where many might 
switch from dolphin to konqueror, I guess.)

Of course, this was exactly the sort of thing konqueror fans were worried 
about when dolphin became kde's default file manager... konqueror losing 
development focus and various bits of it going bug-riddled and broken 
until it's no longer of much use.  Oh, well...

> Is there perhaps some additional code that I need to install?
> 
> I retrieved the code: "kde-baseapps/konq-plugins" from the new location:
> 
>      https://projects.kde.org/projects/kde/kde-baseapps/
> 
>      git://anongit.kde.org/kde-baseapps
> 
> But, is there more: "konq-plugins" code somewhere else?

Something else to check altho as I said, it doesn't appear to make a 
difference here:  In konqueror, settings menu, configure extensions, you 
should have the directory filter extension listed and checked.

Maybe try toggling that off, restarting kde, then toggling it back on and 
restarting?  Hey, it used to work many bugs of this sort back on MS. 
<shrug>

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

___________________________________________________
This message is from the kde-linux mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.