Web lists-archives.com

Re: Problems with setting up development environment (for new devs)




Glad to hear you got it up and running. Would you mind submitting a bug report for the issue over at https://invent.kde.org/kde/kdesrc-build/issues?

Also, now's the best time for you to update the wiki page (https://community.kde.org/Get_Involved/development) to increase the clarify for anything you had a hard time with while it's all still fresh in your mind!

VM instructions would be nice too. I've been meaning to add those for a while now. If you start, I'll polish it up! :)

Nate


On 5/5/19 2:11 PM, veqz wrote:
Hi,

This weekend I finally managed to get around to set up a development environment:

1. VM with neon Development/Unstable Edition
2. Followed the guide at https://community.kde.org/Get_Involved/development:
   a. sudo apt install git cmake dialog
   b. Configuring git
   c. Setting up kdesrc-build (kdesrc-build --initial-setup)
  d. Installing all non-KDE dependencies from https://community.kde.org/Guidelines_and_HOWTOs/Build_from_source/Install_the_dependencies#KDE_neon.2C_Debian.2C_Ubuntu.2C_Kubuntu
3. Tried to compile Dolphin: kdesrc-build dolphin --include-dependencies

Which mostly worked. This programme fails to build «gpgme» and «kdewebkit». After asking around on #kde-devel, meven, Jucato, and asturm helped guide me to simply exclude the Qt-parts from the .kdesrc-build.rc file. After this everything seems to run fine.

Just wanted to inform whoever might consider looking at it, that the official guide doesn't work quite like it should.

I've included the two log files which with the error output.

–Tore M. Havn