Web lists-archives.com

Re: Transitioning CI builds of all non-Frameworks from Qt 5.9




El dimarts, 4 de desembre de 2018, a les 20:13:43 CET, Ben Cooksley va escriure:
> On Wed, Dec 5, 2018 at 7:22 AM Albert Astals Cid <aacid@xxxxxxx> wrote:
> >
> > El dimarts, 4 de desembre de 2018, a les 18:10:44 CET, Thiago Macieira va escriure:
> > > On Monday, 3 December 2018 01:30:25 PST René J.V. Bertin wrote:
> > > > Can't you just configure the CI to use Qt 5.10? I think it's not good to
> > > > hardcode an "overzealous" (for lack of a better word) Qt version in
> > > > projects that don't require them AND I think that one should support the
> > > > current LTS release in as many projects as possible as a general rule of
> > > > principle.
> > > >
> > > > There's a reason why those LTS releases exist and that should probably be
> > > > taken into consideration ESPECIALLY for the KF5 Frameworks (remember why
> > > > kdelibs4 was split up)!
> > >
> > > Which is exactly why 5.11.3 (released today) should be picked. It contains all
> > > fixes that 5.9.7 contains, whereas 5.10.1 does not. Moving from 5.9.7 to
> > > 5.10.1 means regressing all those fixes.
> >
> > It doesn't matter, apps need 5.10 to compile, so CI needs to use 5.10.
> >
> > Of course users should be using 5.11.3, but that's a different story.
> 
> So you'd prefer we move to Qt 5.10 then, and then do another move to
> 5.11 when Frameworks moves it's bar up?

Personally, yes, it's much easier to detect apps requiring 5.11 API when they don't pretend to (not sure there's much new api in 5.11 but anyhow). I mean in an ideal world we'd compile each app with their required min Qt version to detect those things, but since that's not possible with the current setup let's settle for the smallest possible version.

And Frameworks requiring 5.11 is still kind of far no?

Cheers,
  Albert

> 
> >
> > Cheers,
> >   Albert
> >
> >
> 
> Regards,
> Ben