Web lists-archives.com

Re: Transitioning CI builds of all non-Frameworks from Qt 5.9




On Tue, Dec 4, 2018 at 9:45 AM Elvis Angelaccio
<elvis.angelaccio@xxxxxxx> wrote:
>
>
>
> On 03/12/18 09:46, Ben Cooksley wrote:
> > Hi all,
>
> Hi Ben

Hi Elvis,

>
> >
> > I've been informed by the PIM developers that they would like to bump
> > the dependency of the Qt version they use, from Qt 5.9 which it's on
> > currently, to Qt 5.10.
> >
> > As a consequence, due to many KDE projects using PIM libraries, their
> > dependency on Qt will also be effectively bumped. To minimize the
> > maintenance cost of this bump for the CI system, I would like to bump
> > everyone up from Qt 5.9 to a newer version of Qt (otherwise we'll end
> > up chasing down build failures for a long time)
>
> It's not clear if you are suggesting to bump the minimum required Qt
> version in each CMakeLists.txt file, or if you are just going to bump
> the Qt version used by the CI server.
>
> Could you please clarify? Thanks!

I'll only be bumping the version used by the CI system, the
applications themselves will be left unchanged.

>
> >
> > As most distributions have moved on from 5.10, and use Qt 5.11 now
> > (and will in many cases soon move to Qt 5.12), i'd like to suggest
> > that instead of going to Qt 5.10, we move straight to 5.11.
> >
> > Because Frameworks has a two versions prior support policy, it'll
> > remain on 5.9 for now until it's ready to move up to 5.10 (assuming
> > 5.12 is a usable Qt version)
> >
> > If nobody has any objections, i'll proceed with this change in around
> > 3 days time.
> >
> > Cheers,
> > Ben
> >
>
> Cheers,
> Elvis

Cheers,
Ben