Web lists-archives.com

Re: Unable to compile KWidgetsAddons




On Thursday, 29 March 2018 15:53:25 CEST Nate Graham wrote:
> In trying to test out a KWidgetsAddons patch, I find that I'm unable to
> compile it on KDE Neon dev unstable the code due to a CMake error:
> 
> 
> CMake Error in autotests/CMakeLists.txt:
>    No known features for CXX compiler
> 
>    "GNU"
> 
>    version 5.4.0.
> 
> Full output available at https://paste.kde.org/piyy4wsnl

Heya,

FYI: The compile-feature [1] is used by the CMake Config files installed by 
Qt. For Qt it is used to figure out when and how to pass the i.e. the resp. `-
std=...` flag for GNU-like compilers for users of Qt.

Usually you get that kind of error in case you're trying to use an unsupported 
compiler for which CMake doesn't know the availability of the C++ features. A 
typical example is Android GCC.

I'm surprised you get that error by a standard GCC...? Would be nice to figure 
out what's going wrong. Maybe `cmake --trace` or `cmake --debug-output` can 
help.

Please check the following link for a work-around:
  https://stackoverflow.com/a/40256862/592636

[1] https://cmake.org/cmake/help/v3.8/manual/cmake-compile-features.7.html

Regards,
Kevin

> My g++ version looks okay:
> 
> $ g++ --version
> g++ (Ubuntu 5.4.0-6ubuntu1~16.04.9) 5.4.0 20160609
> Copyright (C) 2015 Free Software Foundation, Inc.
> 
> 
> Nate


-- 
Kevin Funk | kfunk@xxxxxxx | http://kfunk.org

Attachment: signature.asc
Description: This is a digitally signed message part.