Web lists-archives.com

Re: kdesrc-build and gpgme






Le 21/03/2018 à 09:33, Andre Heinecke a écrit :
Hi,

On Wednesday, March 21, 2018 9:10:14 AM CET Stéphane Ancelot wrote:
my system has got gpgme 1.9 , I don't know if pulling, compiling a new
one is mandatory for kdesrc-build compiling.
No, 1.9 should be fine, so you can ignore the GPGME error and just continue
building other software.

your distro provides and send me the error off list?
The system uses qt 5.6.2 and my qt5 release for kde is 5.10
I enclosed the error.log and configure.log
Have you tried setting the PKG_CONFIG_PATH environment variable?
I did and it is now compiling
What I think happens here is that "moc" is taken from the PATH, which includes
your custom prefix so it is Version 5.10 . But the Qt Include dir / Libraries
are taken from the system -> Version 5.6 . This mismatch breaks.
You are right.
I've opened a task to improve that in GPGME so that it at least results in an
error at configure time. https://dev.gnupg.org/T3852
fine.

Best Regards,
Andre