Web lists-archives.com

kdesrc-build systemsettings error at compile time




Hi, I have some problems compiling systemsettings

enclosed is the error log. Mistake is related to libkworkspace and cmake  , I suppose it is something that must be compiled by kdesrc-build ?

If you have idea on howto solve it ?

Regards,

S.Ancelot

# kdesrc-build running: 'cmake' '/home/sancelot/kdesrc/kde/workspace/systemsettings' '-DCMAKE_CXX_FLAGS:STRING=-pipe ' '-DCMAKE_INSTALL_PREFIX=/home/sancelot/kde-latest'
# from directory: /home/sancelot/kdesrc/build/kde/workspace/systemsettings
-- The C compiler identification is GNU 4.8.5
-- The CXX compiler identification is GNU 4.8.5
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Could not set up the appstream test. appstreamcli is missing.
-- Looking for __GLIBC__
-- Looking for __GLIBC__ - found
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Found KF5Crash: /home/sancelot/kde-latest/lib64/cmake/KF5Crash/KF5CrashConfig.cmake (found version "5.45.0") -- Found KF5ItemViews: /home/sancelot/kde-latest/lib64/cmake/KF5ItemViews/KF5ItemViewsConfig.cmake (found version "5.45.0") -- Found KF5KCMUtils: /home/sancelot/kde-latest/lib64/cmake/KF5KCMUtils/KF5KCMUtilsConfig.cmake (found version "5.45.0") -- Found Gettext: /home/sancelot/UTILS/bin/msgmerge (found version "0.19.8")
-- Found PythonInterp: /usr/bin/python (found version "2.7.13")
-- Found KF5I18n: /home/sancelot/kde-latest/lib64/cmake/KF5I18n/KF5I18nConfig.cmake (found version "5.45.0") -- Found KF5KIO: /home/sancelot/kde-latest/lib64/cmake/KF5KIO/KF5KIOConfig.cmake (found version "5.45.0") -- Found KF5Service: /home/sancelot/kde-latest/lib64/cmake/KF5Service/KF5ServiceConfig.cmake (found version "5.45.0") -- Found KF5IconThemes: /home/sancelot/kde-latest/lib64/cmake/KF5IconThemes/KF5IconThemesConfig.cmake (found version "5.45.0") -- Found KF5WidgetsAddons: /home/sancelot/kde-latest/lib64/cmake/KF5WidgetsAddons/KF5WidgetsAddonsConfig.cmake (found version "5.45.0") -- Found KF5WindowSystem: /home/sancelot/kde-latest/lib64/cmake/KF5WindowSystem/KF5WindowSystemConfig.cmake (found version "5.45.0") -- Found KF5XmlGui: /home/sancelot/kde-latest/lib64/cmake/KF5XmlGui/KF5XmlGuiConfig.cmake (found version "5.45.0") -- Found KF5DBusAddons: /home/sancelot/kde-latest/lib64/cmake/KF5DBusAddons/KF5DBusAddonsConfig.cmake (found version "5.45.0") -- Found KF5Config: /home/sancelot/kde-latest/lib64/cmake/KF5Config/KF5ConfigConfig.cmake (found version "5.45.0") -- Found KF5DocTools: /home/sancelot/kde-latest/lib64/cmake/KF5DocTools/KF5DocToolsConfig.cmake (found version "5.45.0") -- Found KF5Package: /home/sancelot/kde-latest/lib64/cmake/KF5Package/KF5PackageConfig.cmake (found version "5.45.0") -- Found KF5Declarative: /home/sancelot/kde-latest/lib64/cmake/KF5Declarative/KF5DeclarativeConfig.cmake (found version "5.45.0") -- Found KF5Activities: /home/sancelot/kde-latest/lib64/cmake/KF5Activities/KF5ActivitiesConfig.cmake (found version "5.45.0") -- Found KF5ActivitiesStats: /home/sancelot/kde-latest/lib64/cmake/KF5ActivitiesStats/KF5ActivitiesStatsConfig.cmake (found version "5.45.0") -- Found KF5KHtml: /home/sancelot/kde-latest/lib64/cmake/KF5KHtml/KF5KHtmlConfig.cmake (found version "5.45.0")
-- qmlplugindump failed for org.kde.kcm.
-- Could NOT find org.kde.kcm-QMLModule (missing: org.kde.kcm-QMLModule_FOUND)
CMake Error at CMakeLists.txt:55 (find_package):
  By not providing "FindLibKWorkspace.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "LibKWorkspace", but CMake did not find one.

  Could not find a package configuration file provided by "LibKWorkspace"
  (requested version 5.12.80) with any of the following names:

    LibKWorkspaceConfig.cmake
    libkworkspace-config.cmake

  Add the installation prefix of "LibKWorkspace" to CMAKE_PREFIX_PATH or set
  "LibKWorkspace_DIR" to a directory containing one of the above files.  If
  "LibKWorkspace" provides a separate development package or SDK, be sure it
  has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/sancelot/kdesrc/build/kde/workspace/systemsettings/CMakeFiles/CMakeOutput.log".