Web lists-archives.com

Re: Searching for KF5CddbConfig.cmake




Hi Christoph,

Thanks. Well, I always stick to LTS version of distros looking for maximum stability. But it seems a problem for newer software. I wonder whether I could apply any workaround, backport from more recent version or copy missing files or it's not a simple thing?

Thanks again!
K

pt., 23.02.2018, 20:29 użytkownik Christoph Feck <cfeck@xxxxxxx> napisał:
On 23.02.2018 17:29, Konrad Kostecki wrote:
> Hi there!
>
> This is my first message here. Just wanted to say hello all!
>
> I'm compiling fantastic tool soundkonverter in version 3.0.1 (
> https://github.com/dfaust/soundkonverter/releases) on Mint 18.3 (basically
> Ubuntu 16.04) and I can't pass this error message by:
>
> =====
>
> CMake Warning at CMakeLists.txt:35 (find_package):
> By not providing "FindKF5Cddb.cmake" in CMAKE_MODULE_PATH this project has
> asked CMake to find a package configuration file provided by "KF5Cddb", but
> CMake did not find one.
>
> Could not find a package configuration file provided by "KF5Cddb" with any
> of the following names:
>
> KF5CddbConfig.cmake
> kf5cddb-config.cmake
> Add the installation prefix of "KF5Cddb" to CMAKE_PREFIX_PATH or set
> "KF5Cddb_DIR" to a directory containing one of the above files. If
> "KF5Cddb" provides a separate development package or SDK, be sure it has
> been installed.
>
> =====
>
> Can you help me finding a dev package containing this? I tried libkcddb-dev
> and kdemultimedia-dev but it seems they do not contain it.
>
> Thank you for any suggestions!
>
> Have a nice weekend!
> Kokos
>

Hi Konrad,

the package 'libkcddb-dev' looks correct, but it most certainly contains
the old KDE4 version. Please try a recent distribution to compile recent
software. Ubuntu 16.04 is _really_ old when it comes to dependencies in
the fast-moving KDE territory.

Christoph