Web lists-archives.com

Re: [kdesrc-build] qca build failed




On Sun, Jan 21, 2018 at 3:33 PM, Christoph Feck <cfeck@xxxxxxx> wrote:
> On 20.01.2018 17:33, Mathieu Tarral wrote:
>>
>> I'm trying to build KDE from source using kdesrc-build script.
>> However, each time i have tried these last days, it failed on the QCA
>> module.
>
>
> This might have to do with incompatible changes in openssl. Try to switch
> between 1.0.2 and 1.1.0 version.
>
> But I think you can skip QCA for now, because it is only needed for a few
> KDE applications such as Okular, Konversation, and KTorrent (and even there
> might be optional).
>
> Neither KDE Frameworks, nor the Plasma workspaces require QCA.
>

Unfortunately i'm afraid Purpose, a recent addition to Frameworks,
does require QCA.
It only has a couple of users though so you can probably skip building
it if QCA is causing you issues.

Cheers,
Ben