Web lists-archives.com

Re: Failure to build kwin "Could NOT find Qt5FontDatabaseSupport"




Am 2017-08-25 15:47, schrieb Andrey Voropaev:
Hello!

I'm trying to compile plasma-workspace on Linux using command:

"kdesrc-build  --include-dependencies plasma-workspace"

The only thing that fails is "kwin" (and plasma-workspace itself). The
exact error
from the log file looks like this:

Could NOT find Qt5FontDatabaseSupport (missing:
Qt5FontDatabaseSupport_LIBRARY Qt5FontDatabaseSupport_INCLUDE_DIR)

I'm using Qt 5.9.1 (git repo). It is also compiled from sources using:

"configure -developer-build -opensource -nomake examples -nomake tests
-confirm-license"

What could be wrong here?

You need to install the private API of Qt. On a debian based distro that's normally package qtbase5-private-dev

Cheers
Martin