Web lists-archives.com

Re: Cant build KDE EDU Blinken from source code




On Monday, 5 June 2017 13:37:28 CEST Aman Gupta wrote:
> I'm trying to build Blinken using the source but am getting an error
> regarding Phonon4qt5 which i'm not able to resolve. I've attached a
> screenshot with this mail which shows the error. I hope someone may please
> reach out to me for help.

Next time please include more information:
- What distro
- Which version of Blinken

Also, please paste the compilation/configure error in *text* form so one can 
easily copy from it.

Anyhow, from your screenshot one can deduce you're using Ubuntu. CMake reports 
you're missing libphonon4qt5experimental.so.4.8.3.

=> Check which package provides this file, e.g. with 'apt-file':

% apt-file search phonon4qt5experimental.so
libphonon4qt5experimental-dev: /usr/lib/x86_64-linux-gnu/
libphonon4qt5experimental.so
libphonon4qt5experimental4: /usr/lib/x86_64-linux-gnu/
libphonon4qt5experimental.so.4
libphonon4qt5experimental4: /usr/lib/x86_64-linux-gnu/
libphonon4qt5experimental.so.4.8.3

=> Solution: Install libphonon4qt5experimental4 via apt-get.

Hope that helps,
Kevin

-- 
Kevin Funk | kfunk@xxxxxxx | http://kfunk.org

Attachment: signature.asc
Description: This is a digitally signed message part.