Web lists-archives.com

Re: How am i supposed to use arc? - was - Re: Phabricator: All repositories registered - upcoming workflow changes




Write it in a wiki page?

Freundliche Grüße
Boudhayan Gupta
KDE e.V. - Sysadmin and Community Working Groups
+49 151 71032970


On 26 March 2017 at 18:33, Albert Astals Cid <aacid@xxxxxxx> wrote:
> El diumenge, 29 de gener de 2017, a les 8:32:21 CEST, Ben Cooksley va
> escriure:
>> Hi everyone,
>>
>> We've just completed the registration of all mainline repositories
>> (not including Websites or Sysadmin namespaced ones) on Phabricator.
>> Thanks go to Luigi Toscano for providing significant assistance with
>> this process.
>>
>> From this point forward, communities should be moving away from
>> Reviewboard to Phabricator for conducting code review. Sysadmin will
>> be announcing a timeline for the shutdown of Reviewboard in the near
>> future.
>>
>> Projects which haven't yet looked into Phabricator, including getting
>> things like mailing list notifications and projects setup should do so
>> as soon as practical.
>>
>> As part of the registration process, Sysadmin tagged repositories,
>> associating them to Projects. These tags show what a repository is
>> associated with and it's status.
>>
>> This includes things like whether development is currently active (the
>> Historical Archival and Up For Adoption tags), which release unit it
>> is part of (KDE Applications, Frameworks, etc) and the general
>> development effort it is associated with.
>>
>> It would be appreciated if everyone could please check their
>> repositories to ensure they've been tagged correctly. Adjustments can
>> either be sent as replies to this email (include sysadmin@ in CC
>> please) or by asking a member of the Community Admins project on
>> Phabricator to make the change for you.
>
> I tried using arc today, after reading some documentation it seems i need to
> use
>                 arc diff
> to upload a patch, but then i got hit by
>
>
> $ arc diff
> Usage Exception: This command requires arc to connect to a Phabricator
> install, but no
> Phabricator installation is configured. To configure a Phabricator URI:
>
>   - set a default location with `arc set-config default <uri>`; or
>   - specify `--conduit-uri=uri` explicitly; or
>   - run `arc` in a working copy with an '.arcconfig'.
>
>
> And i couldn't find more documentation on how to move forward. Ultimately I
> asked Aleix that told me "copy the .arcconfig file from plasma-desktop".
>
> Since newbies usually don't have Aleix at hand, how do we fix this?
>
> Cheers,
>   Albert
>
>>
>> Thanks,
>> Ben Cooksley
>> KDE Sysadmin
>
>