Web lists-archives.com

Re: Dropping kdelibs4-based applications in KDE Applications 17.12




El dimarts, 15 de novembre de 2016, a les 19:53:43 CET, Ben Cooksley va 
escriure:
> On Tue, Nov 15, 2016 at 11:27 AM, Albert Astals Cid <aacid@xxxxxxx> wrote:
> > El divendres, 11 de novembre de 2016, a les 18:24:42 CET, Christoph Feck
> > va
> > 
> > escriure:
> >> On 11.11.2016 16:45, Dominik Haumann wrote:
> >> > On Thu, Nov 10, 2016 at 11:42 PM, Albert Astals Cid <aacid@xxxxxxx> 
wrote:
> >> >> Hi, my proposal would be to make KDE Applications 17.08 the last
> >> >> release
> >> >> we
> >> >> accept applications based on kdelibs4, that means people have a year
> >> >> until KDE Applications 17.12 to port the applications from the list
> >> >> below to KF5.
> >> >> 
> >> >> The ones that aren't ported we would just drop to unmaintained or if
> >> >> they
> >> >> have an active developer team that somehow doesn't want to move to KF5
> >> >> they could move to "extreagear".
> >> 
> >> Will we still release the KDE4 platform for not-yet-ported extragear
> >> applications (Amarok etc.) with 17.12?
> >> 
> >> If we stop releasing it, then we should also move all unported
> >> applications to 'unmaintained'. Any developer willing to port can
> >> surrect it from there.
> > 
> > I personally think that's a bit extreme tbh, if a group of developers are
> > stubbornly fixated in developing for kdelibs4 and not KF5 I don't see why
> > we should not let them do the releases if they want to.
> > 
> > But this seems a bit hypothetical, I *hope* any actively maintained
> > "extregear" app will be KF5-based in a year :)
> 
> From my perspective, i'd like to drop CI support for Qt 4 based code
> as soon as possible. Keeping it alive requires a whole additional set
> of jobs and associated infrastructure, for something which receives
> little development attention (comparatively).
> 
> Chances are we'll have to keep this support alive until Applications
> 17.08 is released, at which point I think we should drop it
> completely, even if Extragear projects continue to use KDE 4 / Qt 4
> based sources.

Fair (unless someone from those KDE 4/Qt 4 projects steps up to provide the 
womanpower/hardwarepower/anypower needed to keep CI for those running).

Cheers,
  Albert

> 
> > Cheers,
> > 
> >   Albert
> 
> Regards,
> Ben