Web lists-archives.com

Reminder: Please update kde-build-metadata when making changes to repository branch use




Hi all,

Currently there are a series of build breakages on build.kde.org due
to out of date build metadata.
Just a reminder: before beginning ports of projects from Qt 4 to KF5,
you need to:

a) Ensure there is a Qt 4 branch (last stable release will do)
b) Update kde-build-metadata appropriately

This involves updating the "logical-module-structure" file to contain
the correct branch information, and the appropriate dependency-data-*
files to cover the dependencies for the newly ported project as
needed.

The names "kf5-qt5", "stable-kf5-qt5" refer to the latest / stable
development branches for KF5, while "latest-qt4" and "stable-qt4" are
the Qt 4 counterparts to those two for the logical-module-structure
file.

NOTE: If you are porting a library, then under no circumstances should
you leave the "latest-qt4" and "stable-qt4" branch groups marked as
empty ("") as this will break the Qt 4 builds of any application which
depends on the library. This is why it is essential a branch is
created if one does not already exist (the CI system cannot reference
tags).

Thanks,
Ben