Web lists-archives.com

Re: Using Qt 5.7 as dep for master in build.k.o




On Thu, Jul 7, 2016 at 10:34 AM, Aleix Pol <aleixpol@xxxxxxx> wrote:
> On Wed, Jul 6, 2016 at 10:56 PM, Sandro Andrade <sandroandrade@xxxxxxx> wrote:
>> Hi there,
>>
>> I'd like to bump Qt dependency in Minuet to 5.7, so that I can use
>> some features from QtQuickControls2. That'd require upgrading the Qt
>> version used in build.kde.org.
>>
>> Do you see any issues with that? I'm not running any tests or other
>> integration tasks for Minuet yet, so that I could just disable it in
>> build.k.o for now and keep Qt 5.6, but some demands for CI should
>> arrive soon.
>>
>> Cheers,
>> --
>> Sandro
>
> Without knowing how it's actually set up, I'd say ideally we should
> have the CI always running the latest Qt stable version.
> It could be interesting to test it with older versions (it's done for
> some projects like frameworks already, outside of build.kde.org).

No more responses?

Please note that even minor (5.6.0 to 5.6.1 for instance) upgrades in
Qt version require a full rebuild of everything on the CI system, due
to effective binary incompatibility imposed by Qt's plugin loading
system (and real binary incompatibility in their private interfaces
which some parts of KDE use).

>
> Aleix

Cheers,
Ben